Overview

'Growl for Excel' lets you broadcast messages from your Excel spreadsheet to:

  1. Your own computer's taskbar
  2. Other computers
  3. Mobile phones and other mobile devices

If you are running spreadsheets using real-time data you may want to be alerted if a value crosses a threshold. By interfacing with the widely used Growl mechanism, you can broadcast a message describing the alert. Leave the spreadsheet running on your computer unattended. Recieve the notification wherever you are.

Features:

  • Formula Based: No configuration needed in Excel. Alerts triggered by a simple formula.
  • Multiple Alerts: Broadcast as many messages as you'd like for any variety of conditions
  • Controled Broadcast: Alerts are sent only once when the threahold is past. They will not repeat.

Requirements:

  • Growl for Windows: www.growlforwindows.com
  • Microsoft Excel: Version 2003 or later
  • Windows: XP or later, .NET Framework v4.51 or later

Continue with Getting Started

Main Website: GrowlForExcel.Leftek.com
Discuss, Comments, Problems: Forum
Email Support: support@leftek.com


Getting Started

Install 'Growl for Windows'

Download and install from here: www.growlforwindows.com

You may also want mobile devices to receive notifications:

  • iOS: Prowl
  • Android: Squealer
  • Win Phone: Toasty

See more alternative Growl displays here.

Install 'Growl for Excel'

Download from here: Install

Open Excel

Start a new workbook. In cell [A1] enter the number '1'. In cell [B1] enter:

=GrowlIf(A1 = 2, "Test")

Then change cell [A1] to '2'. You should see your 'Test' alert broadcast.


Overview

Excel Functions

Excel functions are all prefixed with "Growl".

GrowlIf()


Overview

Function - GrowlIf(condition, [message])

Description:

When a Condition is met, sends a Growl message.

NOTE: Do not nest this function. It must be the main function in a cell, ie: =GrowlIf(...

GrowlIf() will only send out one alert each time the threshold condition is exceeded. It will not continue to send alerts. However if threshold condition subsides, but then is again exceeded, another alert will be sent. No alert is initially sent if the condition is already met when formula is typed in.

Arguments:

  1. Condition: When changes from FALSE to TRUE, a growl will be sent. TRUE to FALSE will not send a message. (required TRUE/FALSE value)
  2. Message: Message to be sent to Growl when Condition becomes TRUE. If omitted, a blank ('') message will be sent. (optional Text value)

Example:

=GrowlIf(B5 > 10, "Price has been exceeded")

Example time-flow:

1) Enter formula with Condition initially: | FALSE | TRUE
2) Text initially displayed: | "Never Growled" | "Already TRUE" (but no Growl sent)
3) Condition then changes to TRUE. Cell text: | "Growled @ XX:XX:XX" (Growl sent) | stays "Already TRUE" (no Growl sent)
3) Sheet recalcs. Condition still TRUE. Cell text: | stays "Growled @ XX:XX:XX" (no Growl sent) | stays "Already TRUE" (no Growl sent)
5) Condition then changes to FALSE. Cell text: | "Reset @ YY:YY:YY" | "Reset @ YY:YY:YY"
6) Condition then changes to TRUE. Cell text: | "Growled @ ZZ:ZZ:ZZ" (Growl sent) | "Growled @ ZZ:ZZ:ZZ" (Growl sent)


About

Website: GrowlForExcel.Leftek.com
Discuss, Comments, Problems: Forum
Email Support: support@leftek.com

Copyright Information

©2015 by Leftek Software